Problem With Midi

  • I hope someone here can help me sort this problem out. I have been using DMXControl for some time now and have used the Softdesk feature with great success. I now want to use Open Stage Control to send MIDI to DMXControl. I started with a very simple project in DMXControl 3 (latest version). The project contains only one fixture and nothing else. I use DMXControl to select the MIDI In/Out device and connected to an OSC fader widget. When using the fader very slowly things appear to work correctly. But move the fader quickly and the fader will jump up/down and eventually flood the network with MIDI messages. So I stopped OSC and opened up Protokol to debug incoming MIDI messages sent by DMXControl. Once I open the project in DMXControl, this is the MIDI information it sends:


    RECEIVE | ENDPOINT(loopMIDI) TYPE(CONTROLCHANGE) CHANNEL(1) DATA1(13) DATA2(50)

    RECEIVE | ENDPOINT(loopMIDI) TYPE(CONTROLCHANGE) CHANNEL(1) DATA1(13) DATA2(50)

    RECEIVE | ENDPOINT(loopMIDI) TYPE(CONTROLCHANGE) CHANNEL(1) DATA1(13) DATA2(50)


    Why does DMXControl send the same information 3 times? Is this normal? Isn't once enough? It's impossible to use MIDI to control a DMXControl fader. DMXControl will flood the network with MIDI messages and bring everything down.


    I must be doing something wrong, but I can't figure out what that is.

  • Hey Rico,


    at the moment I´m doing something similar, I had to do several stuff outside of DMXcontrol. For example I had to turn off all Midi-CC Commands on which some faders, pads and encoders where configured and switch them to normal midi-notes, in my case switching them really low notes helped, I had to put my Faders and Touchpads to notes with a manufacturer tool. Then I made a enviroment only for testing. In DMXc I hat to go to type Fader for my Faders and they worked pretty good then. My Touchpads didn´t work till I changed the Threshold inside the MidiConfiguration Panel on the right screen from 60-100 to 1 , so the aftertouch behavoir is switched off. On some Controlers you can set the min max for the Range, this should be 1-127 not more, some devices will start to go nuts when something like a finescaling is active.


    Hope this helps.


    Regards André

  • I suspect DMXControl has an issue with MIDI feedback which floods the controller with useless messages. It replies 3 times with the same values. You can add delays and other tricks to fake it, but DMXControl will still reply with the same information many times over. I've reported this as a bug, but haven't received a reply. The best solution for me at this point is to turn MIDI out OFF and forget about the feedback.