Stream Deck- Setting up and using with input assignment

  • Hi, I'm moving over from a Midi desk (APC Mini) to a Stream Deck (15 key) to control my lighting.

    I've installed the stream deck application (and closed it on my windows 10 machine), but still can't see any instance of it here on the input assignment. From what I understand in one of the 'did you know' guides, that the stream deck will be accessed via it's serial number on the input assignment (so you can run more than one).

    Do I need to do anything within DMX Control 3.2 to activate the stream deck and make it visible?


    The stream deck is working properly. When I plug it in, it lights up with the stream deck logo, and when I launch the stream deck application, the middle button shows welcome. I just can't see it within DMX control (I've restarted windows and DMX Control since).


    Thanks all :-)

  • Many thanks for the reply!

    I can't see anything for a MacroBoard branch in the Input Assignment - maybe I'm looking in the wrong place? I have attached a screenshot.


    Where are the logfiles saved? Edit - think I've found the logfile. Let me know if this is correct.

  • I backed up the folders, and uninstalled all copies (3.2 and 2.xx) on my system. Reinstalled a fresh copy of 3.2, and still can't see any instance of stream deck on the input assignment.

    I also deleted the streamdeck program and control centre before reinstalling DMXcontrol 3.2.


    I have attached a screenshot of the input assignment.


    Can you let me know what log files that you need, and where I can find them.

  • Hi, you can export all logfiles (GUI and Kernel) via the export function in DMXControl 3. Just click "Help"=>"Logfiles"=>"Export Logfiles" in the upper menu and you'll get a zip file with all logfiles of the last ten starts of DMXControl 3 packed together.

    Regards

    JP

    im Falle eines Falles klebt Gaffa einfach alles, denn Gaffa ist dein Freund und Helfer :thumbup:

  • Tell me something about the setup
    Is Kernel and GUI running on the same PC, is it a VW
    Is the Streamdeck working with the StreamDeckSoftware on the Port
    Firmwareversion of the StreamDeck
    Is the animated Loge shown wenn you connect the streamdeck while DMXC3 is running?


    Test 1:

    Plug in teh Streamdeck and then Start DMXC3.2- The Animation has show up

    Test 2:

    Start DMXC3.2 and wait for complede startup, Plug in teh Streamdeck and then- The Animation has show up

    Test 3:

    Start The Kernel on one PC and the GUI on a other PC, Connect them per Network(Cable) and Connect the Session:
    Plug the Streamdeck in each PC hase to result in an the Animation
    Test4 :
    Test 3 But Kernel and GUI Switched on the PCs

  • Everything is running on the same PC. I'll set up a second PC to try networking.


    When I plug the stream deck into the pc (directly - not via a usb hub) it lights up with the stream deck logo. I installed the stream deck application, and I got a welcome button on the middle. I could also assign images and text to the various buttons, so I assume that all was ok. As nothing was working with DMX Control, I uninstalled the stream deck application at the same time that I reinstalled DMX Control 3.2. Do I need to install the stream deck app again?


    When DMX Control is running, if I unplug the stream deck and re-plug it in, it shows the logo, but does not show up with any animations. I assume that I am correct in saying that I should not be running the stream deck application when DMX Control is running?


    My stream deck was only purchased yesterday, so I would assume that it is running recent firmware. I may need to reinstall the stream deck app again to check this?

  • I already reinstalled the stream deck software. Firmware is 1.02.004 The welcome button is showing up again now that the stream deck app is running, so I guess that everything is connecting ok.

  • I have the kernel running on my desktop pc, and the gui on my laptop. The dialogue is displayed to connect to a server, and my desktop (Acer i5) is listed. However, the connection type is only listed as local - it won't allow me to change this to remote.


    My laptop does not have a lan port. It is connected to my router via wifi, and my desktop is connected to the router via lan.


    I'll try it the other way around.

  • Hi,

    it won't allow me to change this to remote.

    this is a little display bug. You can click on the dropdown and klick the up or down key on your keyboard. With this you can change the setting between "local" and "remote".

    im Falle eines Falles klebt Gaffa einfach alles, denn Gaffa ist dein Freund und Helfer :thumbup:

  • It's the same the other way around. I am running the kernel on my laptop, and the gui on my desktop. My desktop is showing my laptop under found servers, but it won't allow me to click on it, or change the type from local to remote. Is there something else that I need to be doing in order to make the connection?

  • I have got the laptop to connect to the kernel on my desktop. The stream deck is connected to my desktop.


    Assuming that I am looking in the correct place, nothing is listed under the input assignment on my laptop for the stream deck.


    I was unable to get my desktop to connect to my laptop. I will try again.